DVWA

From ICO wiki
Revision as of 11:47, 5 May 2012 by Dslokov (talk | contribs)

Damn Vulnerable Web App (DVWA)on PHP/MySQL veebirakendus mis on turvaaugu täis. Selle peamisteks eesmärkideks on olla abiks julgeoleku spetsialistidele oma oskuste ja vahendite testimiseks, ning arendajatele näidiseks kuidas et tohi oma rakenduse programmeerida.

Eelduseks on arvutisse eelpaigaldatud Veebiserver(nt Apache), MySQL andmebaasimootor koos teadaoleva kasutajanimega ja salasõnaga ning PHP tugi, ning unzip arhiivi lahti pakimiseks.

wget http://dvwa.googlecode.com/files/DVWA-1.0.7.zip apt-get unzip kui ei ole unzip DVWA-1.0.7.zip mv dvwa /var/www

teeme lahti veebilehitsejaga http://127.0.0.1/dvwa/index.php kui vajalikud moodulid on paigaldatud siis ilmub jargmine pilt (Joonis1).

Joonis1.png

Vajutame "here" linki peale.

Joonis2.png

Ette tuleb andmebaasi loomise leht, vajutame "Create / Reset Dataase". Kui MySQL root salasõnaks on midagit muut peale tühja salasõnat siis tuleb veateade "Could not connect to the database - please chack the config file ". selleks tekstiredaktoriga teeme lahti konfiguratsioonifaili nano /var/www/dvwa/config/config.inc.php seal tuleb ülevaadata MySQL kredentials

$_DVWA[ 'db_user' ] = 'root';

$_DVWA[ 'db_password' ] = 'TEIE SALASÕNA';

$_DVWA[ 'db_database' ] = 'dvwa';

kui see tegevus tehtud vajutame uuesti "Create / Reset Dataase". Kui rekvisiidid olid õigesti sisestatud siis ilmub järgmine pilt kus räägitakse millised tehingud olid teostatud.

Joonis3.png


Dmitri Šlõkov AK31